Skip Navigation

Meta Help Center

Meta is committed to supporting a performant and delightful experience for our users. As such, we recommend using one of the following browsers:

 

512px-Google_Chrome_icon__September_2014_.svg.png

Chrome: Version 60 and higher

safari.PNG

Safari: Version 10.1 and higher

firefox-logo.PNG

Firefox: Version 54 and higher

edge-logo2.PNG

Edge: Version 15 and higher

 

If you are using an older version of a supported browser or an unsupported browser, some of the features on Meta may not display correctly. Most browsers can be set to automatically update to the latest versions. 

As of Feb 5, 2020, Meta will no longer support the use of Internet Explorer. Because Microsoft no longer updates Internet Explorer, this browser is missing key security and functionality updates. If you prefer or are required to use a Microsoft browser, please use Edge.